SvnBridge Server: can browse but not check out

Aug 12, 2009 at 6:20 PM

I've installed SvnBridge server on a Windows 2003 Server/TFS 2008/IIS 6 installation

I followed the instructions and am able to browse the repository with TortoiseSVN's Repository browser. It sees all of the files and folders in the project.

If I try to perform a checkout, however, I get the following in the Checkout dialog:

Command: Checkout from http://server:8081/<PathToProject>, revision HEAD, Fully recursive, Externals included 
Added: C:\Temp\test2\<projectFolder>\application 
Error: REPORT of '/!svn/vcc/default': Could not read chunk size: An existing  
Error: connection was forcibly closed by the remote host. 
Error:  (http://server:8081

In the target directory, I have a .svn directory, and the first of the folders in the project, whose only contents are an .svn directory.

The contents of the top .svn directory are:


All of these directories are empty. The single file is .svn\entries which contains:



<20 blank lines>


The .svn directory in the only project folder created is similar.

Client is TortoiseSVN V1.6.4 running on Windows XP Pro SP3 fully updated.

The TFS Server/SvnBridge server is on the local network.



Aug 14, 2009 at 7:22 PM

There is an incompatibility with TortoiseSVN v1.6.4 and the last release of SvnBridge.  Until we get a chance to create a new release, what you can do is get the latest source code and compile from that.

Oct 23, 2012 at 11:08 AM

I am experiencing the same problem where I am able to browse but cannot check out.

What I am doing is

1) Migrate my SVN repo (1.6*) to TFS which sits on TFS server

2) Setup SVNBRidge V6 server side on TFS server

3) able to browse the source code via Internet Explorer on TFS server and also my local machine

4) Install TortoiseSVN on my local machine but failed to do a checkout.

What version of SVNBrdige and TortoiseSVN works well?


Nov 16, 2012 at 10:57 AM

I have this problem as well. I've tried going back to TortoiseSVN version 1.6.6 and 1.7.0 but to no avail. Can anyone advise the versions they have when it works for them please?

Mar 21, 2013 at 2:32 PM
Edited Mar 21, 2013 at 2:33 PM
Same thing here. I can browse repository but when I try to check out anything i get "Could not read chunk size: An existing
Error: connection was forcibly closed by the remote host."

SvnBridge version: v6
TortoiseSvn versions tried: 1.7.0, 1.7.11
TFS version: 2010 (10.0.40219.339, SP1)
IIS version: 7.5.7600.16385
OS version: Windows Server 2008 R2, SP1, 64-bit

SvnBridge installed on the same server as TFS and exactly according to instructions.

It appears I can check out individual files but not entire folders.
Apr 9, 2013 at 4:26 AM
me too, any one has the way to resolve this problem?