Configuring SVNBridge on a Server - Authentication issues

Jun 25, 2009 at 9:48 PM

I've got SVNBridge-Server installed. 

(Hint: If your server won't start and you get an error: "The Process cannon access...." netstat is your friend.  McAfee Enterprise likes to bind to 8081)

So, I've got the website started on port 8082.  I try and do a checkout with TortoiseSVN and this URL:

http://server:8082/Project

I get the following error:

Error:  Server sent unexpected return value (500 Internal Server Error) in response to

Error:  OPTIONS request for 'http://server:8082/Project'

I'm using IIS 6.0 on Win 2k3

I've tried TortoiseSVN 1.5.4 and 1.6.2

The IIS Logs look like:

2009-06-25 21:26:02 W3SVC279708510 10.87.183.210 OPTIONS /InFusion - 8082 - 10.87.182.204 SVN/1.6.2+(r37639)/TortoiseSVN-1.6.2.16344+neon/0.28.4 500 0 0
2009-06-25 21:31:20 W3SVC279708510 10.87.183.210 OPTIONS /InFusion - 8082 - 10.87.182.204 SVN/1.6.2+(r37639)/TortoiseSVN-1.6.2.16344+neon/0.28.4 500 0 0
2009-06-25 21:37:41 W3SVC279708510 10.87.183.210 OPTIONS /Gemini - 8082 - 10.87.182.69 SVN/1.5.4+(r33841)/TortoiseSVN-1.5.5.14361+neon/0.28.3 500 0 0
2009-06-25 21:44:32 W3SVC279708510 10.87.183.210 OPTIONS /InFusion - 8082 - 10.87.182.204 SVN/1.6.2+(r37639)/TortoiseSVN-1.6.2.16344+neon/0.28.4 500 0 0
2009-06-25 21:45:07 W3SVC279708510 10.87.183.210 OPTIONS /InFusion - 8082 - 10.87.182.204 SVN/1.6.2+(r37639)/TortoiseSVN-1.6.2.16344+neon/0.28.4 500 0 0
2009-06-25 21:45:28 W3SVC279708510 10.87.183.210 OPTIONS /InFusion - 8082 - 10.87.182.204 SVN/1.6.2+(r37639)/TortoiseSVN-1.6.2.16344+neon/0.28.4 500 0 0
2009-06-25 21:45:49 W3SVC279708510 10.87.183.210 OPTIONS /InFusion - 8082 - 10.87.182.204 SVN/1.6.2+(r37639)/TortoiseSVN-1.6.2.16344+neon/0.28.4 500 0 0

Where InFusion and Gemini are my two root projects.

Any ideas on where to go next?

 

Jun 25, 2009 at 10:40 PM

Check the SvnBridge logs folder.

Jun 25, 2009 at 10:52 PM
Edited Jun 25, 2009 at 11:14 PM

There is nothing there....

I've set the logs up in the C:\SvnBridgeLogs directory.  It exists, but there is nothing in that directory.....


My bad... I went back, re-read the instructions, and realized that I had checked the "allow anonymous access.  Sorry.  So many pretty buttons and boxes and options.....<grin>

So that's unchecked now.

Now TortoiseSVN comes up with a username and password request.  I try my network user name and password and nothing seems to work.

I suspect that it's the settings on the authentication and access control / Authentication Methods that is the problem.....

I suspect that it has something to do with our Active Directory settings......

I'll talk with them and post the solution....

Sorry about that.....Darn Sysadmins......

 

Jun 26, 2009 at 4:18 PM
Edited Jun 26, 2009 at 5:04 PM

Here's where I went:

When I connect to the SVNBridge website with TortoiseSVN it asks me to authenticate, I type in my Domain credentials, and it fails after 4 attempts.  The error message was:

authorization failed: Could not authenticate to server: rejected Digest challenge.

I have tried setting other authentication methods:  integrated, digest, and basic.  I've tried setting the realm to our domain with either a simple domain or a fully qualified one from the select box. 

I've tried browsing to the site using IE7 and Firefox 3.  Both of these give me the authentication dialog box, and I get the same results:  I try four times and it fails. 

I've tried typing in my login name by itself or with the quaifying "domain\login"

So, I know a lot of things that don't work.  I just don't know that one thing that does..

I believe the answer is that each Active Domain user would have to have their the check box "enable reversable encryption" under the account tab checked and then make a new password.

But that goes against our security guy's wishes, so I guess we'll just have to use the client. 

More information:

From http://technet.microsoft.com/en-us/library/cc738318(WS.10).aspx:

"Users have a valid Windows user account that is stored in Active Directory on the domain controller, with reversible encryption enabled."

This was a dead end for me. 

I was just looking for a solution that I could use on the server and not have to worry about the clients, but I guess I"m installing TortoiseSVN any way... we'll just add one more....

 

Jul 15, 2009 at 7:31 PM

Has anyone been able to find a solution to this? My logs are empty and it wont authenticate I have enven tried the Reverse encryption as stated above.

Sep 16, 2009 at 4:40 PM

Hello

I ran into the issue of the continous authenticate w/o success.  The problem was the AppPool I had setup for the site (IIS 6.0, Win 2k3, TFS 2005sp1) was running as a user that did not have rights to run as an IIS process.  Once I add the said user to the IIS_WPG group all was well, this user is also an admin on the server.  If you don't want to do that, you can use Network Service but it needs to have TFVC rights, otherwise, there be an access failure.

Hope this helps,

BJHop

Aug 4, 2011 at 4:46 PM

My how time flies.... I finally got around to trying this, again.  And was having the same problems.  

For those following at home.  My configuration is TFS2008 with a two server configuration.  

On my app tier, i have Windows Server 2003 R2 running IIS 6.0

I followed the steps at http://svnbridge.codeplex.com/documentation.  I did have to change the C:\winnt to a C:\windows for things to work.  

And I was still getting a 500 error and in the event log, getting a "access denied" error to both the log directory and the web directory.  

The solution was to:

  • Change the Application Pool of SvnBridge to the same one that TFS was using, in my case "Microsoft, Team Foundation Server" (The error changed to a 503 error and started giving me error logs in the log directory.  
  • On the SvnBridge Website Properties->Home Directory Tab, I changed the execute permissions to "Scripts and Executables"  Don't know if this was necessary.  I'm a IIS neophyte.  
  • Change the TfsUrl in the web.config to http://localhost:8080/.  (I removed the "tfs" of the default.  

So my web.config looked like

  <appSettings>
    <add key="TfsUrl" value="http://localhost:8080/" />
    <add key="LogPath" value="C:\SvnBridge\Logs" />
  </appSettings>

I think this documents what I did to get it working.  Now my embedded developers can start using TFS.
If any of this is unclear, please ask.