Unable to connect to repo

May 7, 2008 at 10:37 PM
Tried both the current SvnBridge release, and build from the latest code, but I cannot successfully get any Subversion client, including Tortoise to connect to a CodePlex repository. In all cases, I get the error message below. For example, when trying to co on http://localhost:8081/tfs05.codeplex.com/IronPythonStudio, I get the follwing:

svn: The path was not part of a repository
svn: PROPFIND request failed on '/'
svn: '/' path not found

Additionally, proxy information has been entered in the UI, but it does not appear to persist. If the Settings dialog is opened, the proxy details are always empty.
May 7, 2008 at 11:35 PM
Solved: A combination of a SvnBridge.exe.config with proxy information, and a modification to the Subversion servers file with a group for the bridge seems to have solved the issue. I can now browse repos both through SvnBridge and plain HTTP(S).

Additions to .\Application Data\Subversion\servers:

groups
codeplex = localhost

codeplex
http-proxy-host = localhost
http-proxy-port = 8081