SvnBridge Errors out when installing

Mar 24, 2008 at 11:55 PM
Hi,
When I try to install SvnBridge, I get the following error:
"The TFS Server URL does not appear to a TFS Server"

I gave 8081 as the Bridge port and
Team Foundation Server as : https://tfs04.codeplex.com

Any help is greatly appreciated. tfs04.codeplex.com seems to be my project's server address.

Thanks,
Adi.
Mar 25, 2008 at 12:06 AM
Are you using the release version, or are you using the latest source code and compiling a release build from that? You should be compiling the source code directly and generating a release build from there. If you aren't doing this, that is the first step. See if you still have the issue afterwards.
Mar 25, 2008 at 12:18 AM
I was using the released version. It used to work for me previously but now it stopped working. I just downloaded the sources but the sources don't compile. I am getting the the following errors:
The type or namespace name 'ICanValidateMyEnvironment' could not be found (are you missing a using directive or an assembly reference?) C:\SvnBridge-17068\SvnBridgeLibrary\Infrastructure\FileLogger.cs 9 40 SvnBridgeLibrary

I seem to be missing the following references:
Microsoft.TeamFoundation
Microsoft.TeamFoundation.Client
Microsoft.TeamFoundation.VersionControl.Client
Microsoft.TeamFoundation.WorkItemTracking.Client

Any idea where I can get them?

Thanks,
Adi.


MrDoomMaster wrote:
Are you using the release version, or are you using the latest source code and compiling a release build from that? You should be compiling the source code directly and generating a release build from there. If you aren't doing this, that is the first step. See if you still have the issue afterwards.

Mar 25, 2008 at 3:41 AM
There's about 8 projects in the SvnBridge solution, however the SvnBridge and its library project both should compile fine, which is the minimum required. If the test projects fail that usually doesn't get in my way. Check to make sure those errors aren't from the test projects.
Mar 25, 2008 at 7:49 PM
I am getting the errors from the projects SvnBridge, SvnBridgeLibrary, SvnBridgeViaiis. They all are related to missing reference for ICanValidateMyEnvironent as follows:

The type or namespace name 'ICanValidateMyEnvironment' could not be found (are you missing a using directive or an assembly reference?)

Thanks,
Aditya.


MrDoomMaster wrote:
There's about 8 projects in the SvnBridge solution, however the SvnBridge and its library project both should compile fine, which is the minimum required. If the test projects fail that usually doesn't get in my way. Check to make sure those errors aren't from the test projects.

Mar 26, 2008 at 3:31 AM
Are you using the vs 2005 project?
If so, you probably need to add that to the project. It is located at: SvnBridgeLibrary\Interfaces

We currently work with 2008 projects