Compatible with TFS 2010 Beta 2

Dec 4, 2009 at 8:55 PM

Is the current release compatibel with TFS Beta 2 2010

Dec 6, 2009 at 1:28 PM


Apparently not compatible yet...

I'm trying to connect to TFS 2010 beta 2 server using TortoiseSVN and svnbridge but have not been successful.

I'm getting "500 Internal Server Error in response to OPTION request for...url..." In TortoiseSVN repo browser and "404" in svnbridge errors.

Tried to connect using all of the following urls (and all fail with "404"):






Any suggestions on how to make this work if possible?




Dec 10, 2009 at 5:10 PM

Hello SvnBridge team, can we get some love?

At least give us some pointers, I suspect that the new "Project Collection" features in TFS 2010 is the reason this is not working.


Dec 10, 2009 at 5:16 PM

Logged work item 15300 to track this.


Dec 10, 2009 at 10:46 PM

Oh man need this fix badly.  Hope it happens soon.

Jan 15, 2010 at 6:42 AM


Probably would NOT install TFS 2010 if we would've realized that SvnBridge would not work

Would consider assisting and will certainly help testing

Thank you

Jan 15, 2010 at 10:56 AM


Same here.  I started creating new projects in TFS 2010 Beta 2 but I didn't realize SvnBridge wasn't compatible yet.  Our non-.NET devs are currently using third-party SVN while .NET devs are using TFS 2010 - for the same project.

Not a showstopper but also not ideal :)


Apr 3, 2010 at 2:34 AM

I have downloaded and altered sources to the point of making the IIS-hosted version of SvnBridge work with TFS 2010 RC and TPCs.

How do I proceed w/ contributing my changes?

Apr 6, 2010 at 11:01 AM



Could you please upload it to rapidshare or similar site and give me the link to download it?

Apr 7, 2010 at 12:52 AM


Can you send your modded source/binaries to

(For my own use/testing, hope your mods get official soon)


Apr 12, 2010 at 11:36 PM

Hi Valorekhov,

You could try uploading it as a patch.  I don't know if they'll choose to apply it, but either way it will be available to the community for us to use.


Jun 3, 2010 at 3:21 PM


Has there been any progress on getting this to work with TFS 2010?   



Jun 9, 2010 at 2:05 PM
Hi guys, Anyone having luck with this? Our application team upgraded and broke everything else we linked to via the bridge... Thanks!
Jun 23, 2010 at 8:58 PM
TFS 2010 support is a must !!!
Jun 24, 2010 at 7:34 AM

There was some changes in source code related to TFS 2010 support made by colint. But when i tried to run SvnBridgeServer compiled frum sources, i was not able to make it work properly against TFS 2010 (TFS - ver 10.0.30319.1 (RTM), Windows Server 2008 R2, IIS 7.5.7600.16385).

Are the installation instruction same as for stable release:

SvnBridge Server - IIS 7:
Create a folder on your TFS App tier and unzip the contents of into the folder
Edit the web.config and update the LogPath configuration value
Using IIS Manager, create a new website called "SvnBridge"
Specify TCP port 8081
Specify path is the folder where you unzipped the contents of
After creating the website, click on the Authentication icon and make sure only ASP.NET Impersonation and Digest Authentication are enabled.
Using TortoiseSVN, run a checkout using the following path: http://<yourwebserver>:8081/<projectname>


Or have we do something in different way to make compiled version to run?




Jul 7, 2010 at 10:13 PM
Edited Jul 7, 2010 at 10:34 PM

Let me share my successful experience.

I compiled the latest version, copied the dlls from the bin directory to the server - here is the setup.

You will get an error at first.

Then run the Perf counter installer "AS ADMINISTRATOR"

It should say "Successfully ...."

Refresh and voila! 

Jul 7, 2010 at 10:30 PM
Edited Jul 7, 2010 at 10:35 PM

Thanks guys.

Jul 9, 2010 at 9:44 AM
I have talk with colint via e-mail. He wrote me some useful notes: You should configure web.config:
1) Make sure the TfsUrl in your web.config is pointed at the correct TFS2010 collection URL (i.e. http://servername:8080/tfs/collectionname)
2) Due to new TFS2010 security restrictions you will need to add a read only account onto your TFS server as follows:
a. Pick an account or create a new account on a domain on which the TFS server will recognize

b. Add that account into the TFS global security list w/ rights to view collection-level info or view server-level info

c. Add read rights to all projects’ source control on the TFS server

d. Add that account into the web.config:
<add key="ReadAllUserDomain" value="<YourDomain>" >
<add key="ReadAllUserName" value="<YourUserName>" >
<add key="ReadAllUserPassword" value="<Pass>">
Jul 13, 2010 at 4:29 PM
Edited Jul 13, 2010 at 4:31 PM


Thanks, it worked for me.

I had to compile the latest source code (run Build.bat in the source root; the website is located in the SvnBridgeViaIis folder), and also follow Maxmiracle's instructions.

Note that the ReadAll account can have more access than just read priviledges; although, I don't know if it's recommended.

However, I also had to set DomainIncludesProjectName to False in the web.config file.  It was True by default.  E.g.,

    <add key="DomainIncludesProjectName" value="False" />
    <add key="TfsUrl" value="http://ourTFSServer:8080/tfs/Default" />

(Default is the name of our primary TFS collection.)

Then I was able to connect in TortoiseSVN using the following URL:


- Dave

Aug 2, 2010 at 2:58 AM

Dave, thank you for your mention about the DomainIncludesProjectName.

I was staring at that wondering why it was true when I remembered the URL format of the SvnBridge project

A quick Google search and a long read to get to your comment at the bottom and a few hours of pounding my head against the wall ends in success!

A couple of quick notes if anyone is wondering. I didn't have 2008 installed so I upgraded the source code to 2010 and the website to a 4.0 target hosted on IIS 7.

I am also running the application with Digest Authentication disabled and Windows Authentication enabled. It is working and we even have iMac users connecting to TFS using a windows login.

I have limited experience with SVN, iMac, iPhone and iPad development (nice way of saying I don't know anything about it). Can anyone tell me if Windows Authentication is a bad idea and we should use Digest?


Oct 11, 2010 at 11:39 PM
Edited Oct 19, 2010 at 5:46 PM

After some more recompiling I was able to get it working.  I had to enable only Basic Authentication.  I also had to compile a different CodePlex project called "CodePlex Client" to fix an issue with TfsLibrary.dll.  More details are at this post:


Jan 12, 2011 at 11:44 PM
Edited Jan 12, 2011 at 11:44 PM

I followed Maxmiracle and davedev's instructions from above, I'm able to checkout and commit changes.  Thanks!!

However when I try to do a Svn Commit after a Svn Delete, an Authentication dialog prompts me to enter username and password. After enter correct username and password and click OK, another Authentication comes up, and it just keeps on going..

If I press Cancel, I'll get error committing from TortoiseSVN:

Command    Commit
Delete          C:\tortoiseTest\a.txt
Error            Commit failed (details follow):
Error            DELETE of
Error            '//!svn/wrk/094b6941-0ca4-524a-b8ac-a9db2cb8f0b0/MyProject/Test/a.txt':
Error            authorization failed: Could not authenticate to server: rejected Digest
Error            challenge (http://myServer:8081)

I get similar behaviour and error trying to launch to Repo-browser too.  Any ideas?


Jan 13, 2011 at 6:11 AM

I used basic authentication.  In IIS, try and disable all the other authentication methods except basic.

Jan 13, 2011 at 3:37 PM

I have tried enable only basic authentication and ASP.NET Impersonation.  Still same behaviour on those actions.

Jan 14, 2011 at 12:22 AM

Try it with impersonation disabled.

Jan 14, 2011 at 4:59 PM

With impersonation disabled, I can't even checkout.  The random Authentication dialog prompts only happen to certain actions such as Svn Commit after a Svn Delete.  Looks like a bug:

Apr 19, 2011 at 3:53 AM

I've got svnbridge installed on IIS 7.0 connected with TFS 2010.  When I try to browse to http://myserver:8081/ it works fine, but when I try to run 'svn checkout http://myserver:8081/' it fails even after authentication.  Is this normal?


Apr 22, 2011 at 2:18 AM

It should work, but I am using V4.  Another difference is that I choose a sub directory.  Something like this:

svn co

My TFS server is hundreds of gigs so I would never attempt a checkout of the entire server.