TFS 2008 + SVNBridge server - 404 error

Mar 20, 2012 at 6:23 PM

I keep getting a 404 error in the SVNBridge logs every time I attempt a checkout from SVNBridge. I have SVNBridge (compiled from source) installed on our TFS 2008 box, which is our App Tier machine. Here is my web.config:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
  <appSettings>
    <add key="LogPath" value="C:\SVNBridgeviaIIS\Logs" />
    <add key="LogCancelErrors" value="True" />
    <add key="UseCodePlexServers" value="False" />
    <add key="DomainIncludesProjectName" value="False" />
    <!--<add key="TfsUrl" value="https://tfs01.codeplex.com,https://tfs02.codeplex.com,https://tfs03.codeplex.com,https://tfs05.codeplex.com,https://tfs06.codeplex.com,https://tfs07.codeplex.com,https://tfs10.codeplex.com" />
    -->
    <add key="TfsUrl" value="http://my_tfs_server:8080/Project" />
    <add key="ReadAllUserDomain" value="" />
    <add key="ReadAllUserName" value="" />
    <add key="ReadAllUserPassword" value="" />
    <add key="CodePlexAnonUserDomain" value="" />
    <add key="CodePlexAnonUserName" value="" />
    <add key="CodePlexAnonUserPassword" value="" />
  </appSettings>
  <system.web>
    <httpRuntime maxRequestLength="500000" /> <!-- 250+ MB -->
    <customErrors mode="Off" />
    <compilation debug="true" />
    <!-- Uncomment this httpHandlers element if running under IIS 6.0 / 5.1 -->
    <httpHandlers>
      <clear/>
      <add verb="*" path="*" type="SvnBridgeServer.SvnBridgeHttpHandler, SvnBridgeServer" />
    </httpHandlers>
  </system.web>
  <system.net>
    <defaultProxy enabled="true" />
  </system.net>
  <!-- IIS 7.0 -->
  <system.webServer>
    <modules>
      <remove name="ServiceModel" />
    </modules>
    <handlers>
      <clear />
      <add name="SvnBridgeHandler" path="*" verb="*" responseBufferLimit="0" type="SvnBridgeServer.SvnBridgeHttpHandler" resourceType="Unspecified" preCondition="integratedMode" />
    </handlers>
    <security>
      <requestFiltering allowDoubleEscaping="true">
        <requestLimits maxAllowedContentLength="262144000" /> <!-- 250 MB -->
        <fileExtensions>
          <clear />
        </fileExtensions>
        <hiddenSegments>
          <clear />
        </hiddenSegments>
      </requestFiltering>
    </security>
  </system.webServer>
</configuration>

The error received is:

Exception:   System.Net.WebException: The request failed with HTTP status 404: Not Found.

I think this has something to do with the path to the project I am trying to hit - TFS doesn't seem to be publishing it to the correct place. If I remove the project name from the TFSUrl property and browse to http://my_tfs_server:8082, I see a link to Project, but when I navigate to the project, it gives a 404. Argh. Anyone have any ideas?