Settings Proxy values are not persisted

Apr 29, 2008 at 2:43 AM
Edited Apr 29, 2008 at 2:53 AM
I’m trying to use SvnBridge for the first time and have come across issues either in the tool or with my particular configuration. It seems that the Setting --> Proxy values are not persisted.

Does one have to start and stop for the proxy values to take effect? I have downloaded and compiled latest code release from today (SvnBridge-17930).

Tim.
Apr 29, 2008 at 11:28 PM
I have the same problem. I got SVNBridge to use the proxy server by adding a file SvnBridge.exe.config to the same directory. Then I configure the file manually. The content the file is like:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<configSections>
<sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
<section name="SvnBridge.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowExeDefinition="MachineToLocalUser" requirePermission="false" />
</sectionGroup>
<sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
<section name="SvnBridge.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
</sectionGroup>
</configSections>
<userSettings>
<SvnBridge.Properties.Settings>
<setting name="TfsPort" serializeAs="String">
<value>8081</value>
</setting>
<setting name="UseProxy" serializeAs="String">
<value>True</value>
</setting>
<setting name="ProxyUrl" serializeAs="String">
<value>myProxyUrl</value>
</setting>
<setting name="ProxyPort" serializeAs="String">
<value>80</value>
</setting>
<setting name="ProxyUseDefaultCredentials" serializeAs="String">
<value>True</value>
</setting>
<setting name="ProxyUsername" serializeAs="String">
<value>my\user</value>
</setting>
</SvnBridge.Properties.Settings>
</userSettings>
<applicationSettings>
<SvnBridge.Properties.Settings>
<setting name="TraceEnabled" serializeAs="String">
<value>False</value>
</setting>
<setting name="LogPath" serializeAs="String">
<value />
</setting>
</SvnBridge.Properties.Settings>
</applicationSettings>
</configuration>




TimBajz wrote:
I’m trying to use SvnBridge for the first time and have come across issues either in the tool or with my particular configuration. It seems that the Setting --> Proxy values are not persisted.

Does one have to start and stop for the proxy values to take effect? I have downloaded and compiled latest code release from today (SvnBridge-17930).

Tim.

Apr 30, 2008 at 1:33 AM
Great, editing the SvnBridge.exe.config file worked.