SvnBridge & Digest Authentication Setup

Mar 8, 2011 at 6:59 AM
Edited Mar 8, 2011 at 7:01 AM

Hi All,

I'm having a bit of trouble getting my SvnBridge setup with the following

Windows Server 2008 R2

IIS7 (DigestAuthModule - installed, new site created with configuration files for SVN bridge installed, binding to port: 8081)

TFS 2010

On the client-side, I attempt to explore the REPO:

Right-Click a folder, TortoiseSVN>Repo Browser>

I'm prompted for the remote webserver, so I enter it:

http://<>:8081/ost (where ost is the name of the project in TFS!)

I am now connected, and the HTTP Digest authentication pops up and requests a login and password, at this point, I can't figure out how to configure? I've attempted to use my server administration (Windows Authentication Username/Password...doesn't work, tried adding users to IIS Manager and entering these credentials, but none of them work)

What am I doing wrong?


Mar 11, 2011 at 6:00 PM

Digest Authentication didn't work for me either, had the same problems as you experienced here.  Although not ideal (password in clear text), I was able to get SVNBridge running in IIS7 with Basic Authentication.  

IIS7/TFS 2010

Application Pool running as NetworkService (default settings, seen other posts where a TFS trusted user as suggested here, I didn't need it)
Port 8880 (saw posts where people said port 8081 was required, I was able to run on 8880 without a problem, just make sure to specify port on SVN URL for client)

ASP.NET Impersonation enabled
Basic Authentication enabled (I have my domain in the domain setting, to make user authentication a little easier)
(all other disabled)

So far I have used TortoiseSVN and Dreamweaver CS5 as SVN clients with the repo.

Before I tried this, I verified there wasn't another problem by first hard coding a user in the ASP.NET Authentication, enabling Anonymous Authentication and disabling all others to basically force the bridge to run as that single user.  Then changed to Basic Authentication and all worked.  So, there must be a problem with the way Digest Authentication works in my domain or on my server.

I would certainly prefer Digest Authentication, so if you get it running, please let me know how you did it.


Mar 14, 2011 at 5:14 AM

Are you installing SvnBridge on your TFS app tier machine?

Mar 14, 2011 at 3:01 PM

For me, installed SvnBridge on a another machine, but in the same domain.

Mar 14, 2011 at 7:33 PM

Digest authentication will only work if SvnBridge is installed on the same machine as the TFS App Tier unless you configure "double hop" security which is fairly complicated to set up:

Mar 14, 2011 at 10:27 PM

Thanks for the link.  May move SvnBridge to the TFS App server to allow me to use Digest Authentication. 


Mar 15, 2011 at 7:37 PM
jwanagel wrote:

Are you installing SvnBridge on your TFS app tier machine?


Thanks for the responses guys. My first issue is that I'm probably not technically on an 'TFS app tier' machine.

I'm running in a Hyper-V Virtualbox, and I have minimal memory, so I didn't install the full installation since I just wanted to start out using it for source-control with VisualStudio and add reporting services, etc. etc. later. It's my understanding that the Application Tier is part of this more complete installation?

Mar 15, 2011 at 7:38 PM
Edited Mar 17, 2011 at 8:56 AM
bcinnv wrote:

For me, installed SvnBridge on a another machine, but in the same domain.

I'm going to try your 'basic' authentication to see if I can get connected (-8 and we'll worry about being more secure later.


Ok, so using only "Basic" authentication I was able to connect over HTTP to my server! Sweet, now I run SVNClient on my local machine, and connect! 


I'll have to keep readingm but for now, my "DigestAuthentication" problem is basically worked-around.

Apr 14, 2011 at 9:03 PM
Edited Apr 14, 2011 at 9:43 PM

So here is where I'm at:

I run SVN Bridge Client on my local machine on port 8081.

I want to start doing a repository within a 'collection' which I've created previously on TFS.

I open my repository browser, and it patches me through to the project collection:


So I need to begin some basic 'Import' to begin subversion control.

I right-click the project and import, I'm prompted for my password, and than it seems to hang for a while before asking again for the authentication information, if I 'Cancel' I get the following messages:

authorization failed: Could not authenticate to server: rejected Basic

challenge (http://localhost:8081)

I'm assuming I'm not successfully authenticating, but when I first connect and can 'view' my project it's Ok - so I'm kind of hung up? I think my 'Basic Authentication' isn't correctly confired in IIS even though it would normally work for TFS...maybe I need to tweak my user settings their some more...?


Apr 29, 2015 at 1:31 PM
Please note, that you have to install and enable the role-feature "Basic-Authentication" for IIS (-Site) on your TFS-Server!